Compatible phones and tablets

Updated:

Embrace requires a dedicated phone/tablet to send alert calls and SMS to caregivers, and must be with the user at all times. Caregivers, however, can be at any distance and can have any type of phone to receive alerts. 

Please keep in mind that the paired device must always be connected to the internet in order to send out alerts to caregivers. Also, make sure that the dedicated phone has the latest software version.

Embrace comes with two companion apps, the Alert (which alerts caregivers) and Mate (a smart seizure diary). They are compatible with the following iOS and Android devices:

 

iOS

We support devices running iOS 10 or higher.

We also support the iPod touch 6th and 7th generation and all iPad models that have come out since 2013. Please bear in mind that the Alert App and Mate App are not optimized for the iPad’s screen size.

Android

Devices running Android version 5.0 (Lollipop) or higher, as long as they support Bluetooth Low Energy (BLE / 4.0 / Bluetooth Smart). We do not guarantee full compatibility with custom or unofficial versions of Android running on phones or tablets.

Please note: not all devices that list Bluetooth 4.0 in the specifications, actually support Bluetooth Low Energy. We suggest contacting the manufacturer directly for complete information.

Other mobile platforms

We do not support Windows and Blackberry phones.

Have more questions?