When I plug the device into a USB port, no light turns on.

Updated:

The device should power on when it is plugged into a powered USB port. If the E4 is seated in its charging dock and connected to a powered USB port and you do not see any lights come on try the following steps:
 
(1) First, try powering the E4 on manually by holding down the button for a couple of seconds until the LED comes on. Wait until the green light starts flashing and then reconnect it to the USB 
 
(2) If the E4 does not respond to a button press try a device reset - hold down the button for at least ten seconds. A reset is indicated by a steady white LED.
 
If the E4 does not respond it is likely that the battery is depleted and a failure is present in the charging circuit. Double check to make sure the powered USB port is working and then try the following:
 
Poor Connection to Charging Dock:
(3) Try reconnecting the E4 to it's charging dock and securing it in place - if the E4 does not click in place in the charging dock the clips may be damaged - notify Empatica support and they can review for replacement.
 
Damaged USB Cable:
If the E4 clips into to the charging dock securely there is most likely an issue with the USB cable connection.
(4) Try to gently move the USB cable while it is connected to the E4 to see whether the LED indicator flashes, if it does not try replacing the USB cable with a different cable. If you need a replacement USB cable please contact Empatica Support.
 

Have more questions?